Inicio > Forms & Reports > Java 7 y Weblogic & Forms 11gR2

Java 7 y Weblogic & Forms 11gR2

Muchos clientes tienen dudas sobre si las últimas versiones, tanto del servidor de aplicaciones Weblogic como de las aplicaciones desplegadas Forms, pueden ser compatibles con Java 7. La respuesta es que , pero no todas las versiones de Forms 11g ni de Weblogic sino la combinación de la última versión de Forms 11.1.2.1.0 con la versión de Weblogic Server 10.3.6 o superior. Sólo esta combinación está soportada y certificada por Oracle, según muestra su matriz de certificación.

Otro tema importante, sobre el que surgen dudas en muchos clientes, es si pueden convivir varias versiones diferentes de JRE en un puesto de usuario que tiene que ejecutar diferentes aplicativos Java. ¿Cómo podemos configurarlo en un PC de un usuario?

En este ejemplo nos vamos a apoyar en 2 versiones muy diferentes de JRE, la 1.6.0_04 y la 1.7.0_07, y los aplicativos son Forms 10gR2 (que no puede utilizar la versión JRE 1.7) y Forms 11gR2 (que sí la puede utilizar).

Pasos a seguir:

  • Instalar las dos JRE. Se debe instalar la versión más antigua (1.6.0_04) primero.
  • Configurar el archivo formsweb.cfg del servidor OAS 10gR2. Se debe de añadir el parámetro java_version=1.6.0_04 para obligar a la versión Forms 10gR2 a que se ejecute con el applet Java 1.6.0_04.
  • Configurar el archivo formsweb.cfg del servidor OFMW 11gR2. Se debe de añadir el parámetro java_version=1.7.0_07 para obligar a la versión Forms 11gR2 a que se ejecute con el applet Java 1.7.0_07.
  • Configuración en el panel de control de Java. Esto se debe realizar para que no aparezcan molestos mensajes (“La aplicación necesita una versión anterior de Java. ¿Desea continuar?”) de seguridad de Java cuando ejecutemos los aplicativos Forms 10gR2 que utilizan la versión menos reciente (1.6.0_04). Para ello deberemos ir en nuestro PC Windows a Inicio -> Panel de Control -> Java -> Pestaña Avanzado  y modificar según se muestra en la siguiente imagen:

Panel de Control Java

Archivo formsweb.cfg

Para la correcta ejecución de las aplicaciones Oracle Forms & Reports 10gR2 y 11gR2 en los diferentes navegadores (se ha probado con IE 9+, Firefox 18+ y Chrome 24+), se ha de modificar el fichero formsweb.cfg tal y como se muestra en el siguiente ejemplo:

# Page displayed to users to allow them to download Sun’s Java Plugin.

# Sun’s Java Plugin is typically used for non-Windows clients.

# (NOTE: you should check this page and possibly change the settings)

jpi_download_page=http://java.sun.com/products/archive/j2se/6u12/index.html

# Parameter related to the version of the Java Plugin

jpi_classid=clsid:CAFEEFAC-0017-0000-0011-ABCDEFFEDCBA à Si se ejecuta con Forms 11gR2

jpi_classid=clsid:CAFEEFAC-0016-0000-0014-ABCDEFFEDCBA

Si se quiere ejecutar con Forms 10gR2:

# Parameter related to the version of the Java Plugin

jpi_codebase=http://java.sun.com/update/1.6.0/jinstall-6-windows-i586.cab#Version=1,6,0,12

# Parameter related to the version of the Java Plugin

# jpi_mimetype=application/x-java-applet;jpi-version=1.7

jpi_mimetype=application/x-java-applet;version=1.7 à Obligatorio si se quieren ejecutar con Firefox y Forms 11gR2

jpi_mimetype=application/x-java-applet;version=1.6 à Obligatorio si se quieren ejecutar con Firefox y Forms 10gR2

java_version=1.7.0_11 à Si se quiere ejecuta con esta versión específica y Forms 11gR2

java_version=1.6.0_04 à Si se quiere ejecuta con esta versión específica y Forms 10gR2

# Applet parameter for Sun’s Java Plugin

legacy_lifecycle=false

Categorías:Forms & Reports Etiquetas: , ,
  1. Aún no hay comentarios.
  1. No trackbacks yet.

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: